Servicedesk can't send or receive emails
Incident Report for Datareal
Resolved
This incident has been resolved.
Posted Jan 05, 2023 - 11:39 CET
Update
We are continuing to investigate this issue.
Posted Jan 05, 2023 - 11:39 CET
Investigating
We are currently investigating this issue. If you need to get in contact with us please call us at 08-556 768 90
Posted Jan 05, 2023 - 10:13 CET
This incident affected: Servicedesk.